您的位置:首页 > 其它

POJ2392-Space Elevator

2017-05-21 23:10 501 查看
Space Elevator

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11818 Accepted: 5601
Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100)
and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.
Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.
Output

* Line 1: A single integer H, the maximum height of a tower that can be built
Sample Input
3
7 40 3
5 23 8
2 52 6

Sample Output
48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.
Source

USACO 2005 March Gold

题意:一群牛要上太空,给出n种石块,每种石块给出单块高度,总高度不能超过的最大值,数量,用这些石块能组成的最大高度

解题思路:先进行一次排序,将最大高度小的放在前面,只有这样才能得到最优解,如果将大的放在前面,后面有的小的就不能取到,然后进行完全背包

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

struct node
{
int h, a, c;
}x[409];

int cmp(node x, node y)
{
return x.a<y.a;
}
int dp[50090], sum[50090];

int main()
{
int n;
while (~scanf("%d", &n))
{
for (int i = 1; i <= n; i++) scanf("%d%d%d", &x[i].h, &x[i].a, &x[i].c);
sort(x + 1, x + n + 1, cmp);
memset(dp, 0, sizeof dp);
dp[0] = 1;
int ma = 0;
for (int i = 1; i <= n; i++)
{
memset(sum, 0, sizeof sum);
for (int j = x[i].h; j <= x[i].a; j++)
{
if (!dp[j] && dp[j - x[i].h] && sum[j - x[i].h] + 1 <= x[i].c)
{
dp[j] = 1;
sum[j] = sum[j - x[i].h] + 1;
ma=max(ma, j);
}
}
}
printf("%d\n", ma);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: