您的位置:首页 > 其它

UVA 400 Unix ls

2017-05-21 19:40 337 查看
 Unix ls 
The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the
ls function.

 

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and
format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the
longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to
right.

 

Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer ( ). There will then be
N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to
z, A to Z, and 0 to 9) and from the following set
{ ._- }
(not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

 

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to
R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

 

Sample Input

 

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

 

Sample Output

 

------------------------------------------------------------
12345678.123         size-1
2short4me            size2
mid_size_name        size3
much_longer_name     tiny
shorter              very_long_file_name
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky
Buckwheat      Darla          Mrs_Crabapple  Stimey
Butch          Froggy         P.D.           Weaser
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben
Bobby       Cindy       Jody        Mike        Shirley
Buffy       Danny       Keith       Mr._French  Sissy
Carol       Greg        Lori        Peter


UVA上的题复制不下来什么鬼??= =??
好吧,,
紫书上描述的有点不明白,,应该是每行最多60个字符。。
这个题应用的是STL里面的sort()函数,但感觉和STL没啥关系。。
还有就是print函数那里按照书上的打会报错。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
string file[105];
void print(const string &s,int len)
{
cout<<s;
int i;
int l=s.length();
for(i=0;i<=len-l-1;i++)
{
printf("%c",' ');
}
}
int main()
{
int n;
while(cin>>n)
{
int M=0;
int i,j;
for(i=0;i<=n-1;i++)
{
cin>>file[i];
M=max(M,(int)file[i].length());//最长字符串的长度,强制类型转换
}
int col=(60-M)/(M+2)+1;//最右侧有M个字符,其他列都是M+2字符
int row=(n-1)/col+1;
printf("------------------------------------------------------------\n");
sort(file,file+n);
for(i=0;i<=row-1;i++)
{
for(j=0;j<=col-1;j++)
{
int idx=j*row+i;//因为是竖着排的
if(idx<n)

8e98
{
if(j==col-1) print(file[idx],M);
else print(file[idx],M+2);
}
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: