您的位置:首页 > 其它

The Suspects(POJ-1611)

2017-05-20 21:10 211 查看
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student
is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the
number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


题意:非典传染,0是传染源,跟他直接接触和间接接触的都是传染源,n个人,m个社团,看看最后有多少个传染源;

思路:最基本的并查集;

ps:读题不认真,看了三遍题,才看到0是最开始的传染源。。。。

#include<iostream>
#include<cstdio>
using namespace std;
int a[30005];
int b[505];
int sum;
int find(int x)
{
int r=x;
while(a[r]!=r) r=a[r];
int i=x,j;
while(i!=r){
j=a[i];
a[i]=r;
i=j;
}
return r;
}
void link(int x,int y)
{
int fx=find(x),fy=find(y);
if(fx!=fy) a[fx]=fy;
}
int main()
{
int m,n,s,x,y;
while(cin>>n>>m){
if(n==0&&m==0) break;
sum=0;
for(int i=0;i<=n;i++){
a[i]=i;
}
for(int i=0;i<m;i++){
cin>>s>>x;
for(int j=1;j<s;j++){
cin>>y;
link(x,y);
}
}
int z=find(0);
for(int i=0;i<n;i++){
if(find(i)==z) sum++;
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 并查集