您的位置:首页 > 产品设计 > UI/UE

POJ 3061 Subsequence

2017-05-20 19:29 267 查看

Subsequence

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 14673 Accepted: 6192

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2

10 15

5 1 3 5 10 7 4 9 2 8

5 11

1 2 3 4 5

Sample Output

2

3

Source

Southeastern Europe 2006

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define maxn 100005
int a[maxn],n,sum,S;
void Solve(){
int res=n+1;
int s=0,sum=0,t=0;
for(;;){
while(t < n&& sum<S) sum+=a[t++];
if(sum < S) break;
res = min(res,t-s);
sum -= a[s++];
}
if(res>n) res=0;
printf("%d\n",res);
}
int main(){
int T;
scanf("%d",&T);
while(T--){
scanf("%d%d",&n,&S);
for(int i=0;i<n;i++) scanf("%d",&a[i]);
Solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  尺取法