您的位置:首页 > 其它

[PAT-乙级]1058.选择题

2017-05-18 23:45 288 查看


1058. 选择题(20)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。

输入格式:

输入在第一行给出两个正整数N(<=1000)和M(<=100),分别是学生人数和多选题的个数。随后M行,每行顺次给出一道题的满分值(不超过5的正整数)、选项个数(不少于2且不超过5的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母a开始顺次排列。各项间以1个空格分隔。最后N行,每行给出一个学生的答题情况,其每题答案格式为“(选中的选项个数 选项1 ……)”,按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式:

按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从1开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出“Too simple”。
输入样例:
3 4
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)

输出样例:
3
6
5
2 2 3 4


#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
using namespace std;

struct Problem
{
int score;
int ansCount;
char ans[5];
}buf[102];

int score[1002];
int wrong[102];
int wh[102];

int main()
{
freopen("D://input.txt", "r", stdin);

memset(score, 0, sizeof(score));//每个人的得分
memset(wrong, 0, sizeof(wrong));//某道题目错误的人数,wrong(0)第一道题目错误人数

int n, m, tmp;
scanf("%d%d", &n , &m);
getchar();//'\n'

for(int i = 0; i < m; i ++)
{
scanf("%d %d %d", &buf[i].score, &buf[i].ansCount, &tmp);

// 读入每一道题目的答案
for(int j = 0; j < tmp; j ++)
{
char ch;
scanf(" %c", &ch);
buf[i].ans[j] = ch;
}
buf[i].ans[tmp] = '\0';
}

getchar();//'\n'

for(int i = 0;i < n; i ++)
{
for(int j = 0; j < m; j ++)
{
getchar();//'('
int p;
scanf("%d", &p);

char res[p+1];

// 读入第j道题目的答案
for(int k = 0; k < p; k ++)
scanf(" %c", &res[k]);

res[p] = '\0';
getchar();//')'
getchar();//'\n'

if(strcmp(res, buf[j].ans) == 0)
score[i] += buf[j].score;
else
wrong[j] ++;
}
}

// 找到错的最多的那道题目
int max = 0;
for(int i = 0; i < m; i ++)
{
if(wrong[i] > max)
max = wrong[i];
}

for(int i = 0; i < n; i ++)
printf("%d\n", score[i]);

// max = 0 一道都没有错
if(max == 0)
puts("Too simple");
else
{
printf("%d", max);
// 依次打印错误max次的题目号
for(int i = 0; i < m; i ++)
{
if(wrong[i] == max)
printf(" %d", i + 1);
}
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: