您的位置:首页 > 其它

杭电6027 Easy Summation

2017-05-17 09:51 363 查看

Easy Summation

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/131072K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 2

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

You are encountered with a traditional problem concerning the sums of powers.

Given two integers n
and k.
Let f(i)=ik,
please evaluate the sum f(1)+f(2)+...+f(n).
The problem is simple as it looks, apart from the value of
n
in this question is quite large.

Can you figure the answer out? Since the answer may be too large, please output the answer modulo
109+7.

Input

The first line of the input contains an integer
T(1≤T≤20),
denoting the number of test cases.

Each of the following T
lines contains two integers n(1≤n≤10000)
and k(0≤k≤5).

Output

For each test case, print a single line containing an integer modulo
109+7.

Sample Input

3
2 5
4 2
4 1


Sample Output

33
30
10


Source

2017中国大学生程序设计竞赛 - 女生专场

想法:看懂题目就简单啦!

关键的理解最后一句话please output the answer modulo 109+7.

代码:

#include<stdio.h>

#include<math.h>

#include<math.h>

#define ws 1000000007

int n,k;

long long po(int i)

{

    int j;

    long long sum1=1;

    for(j=1;j<=k;j++)

    {

        sum1=sum1*i;

        sum1=sum1%ws;

    }

    return sum1;

}

long long a[10010];

int main()

{

    int N;

    scanf("%d",&N);

    while(N--)

    {

        int i;

       scanf("%d %d",&n,&k);

       long long as=0;

       for(i=1;i<=n;i++)

       {

           as=as+po(i);

           as=as%ws;

       }

       printf("%lld\n",as);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: