您的位置:首页 > 其它

[PAT-乙级]1032.挖掘机技术哪家强

2017-05-16 20:54 302 查看


1032. 挖掘机技术哪家强(20)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

为了用事实说明挖掘机技术到底哪家强,PAT组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第1行给出不超过105的正整数N,即参赛人数。随后N行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从1开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。
输入样例:
6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:
2 150

#include<stdio.h>
#include<string.h>
int main()
{
//freopen("D://input.txt", "r", stdin);
int n;
int buf[100002];
while(scanf("%d", &n) != EOF)
{
int index, score;
memset(buf, 0, sizeof(buf));
for(int i = 0; i < n; i ++)
{
scanf("%d %d", &index, &score);
buf[index] += score;
}

index = -1; score = 0;
for(int i = 0; i <= 100000; i ++)
{
if(buf[i] > score)
{
index = i;
score = buf[i];
}
}
printf("%d %d\n", index, score);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: