您的位置:首页 > 其它

Red and Black HDU - 1312

2017-05-15 21:43 393 查看
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

InputThe input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

OutputFor each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output
45
59
6
13


#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
char ch[25][25];
int pic[25][25];
int m, n, ans;
void dfs(int r, int c)
{
if(r < 0 || r >= n || c < 0 || c >= m)
return;
if(ch[r][c] == '#')
return;
if(pic[r][c] == 1)
return;
ans++;
pic[r][c] = 1;
dfs(r + 1, c);
dfs(r, c + 1);
dfs(r - 1, c);
dfs(r, c - 1);
}
int main()
{
while(cin>>m>>n && m && n)
{
ans = 0;
for(int i = 0; i < n; i++)
cin>>ch[i];
memset(pic, 0, sizeof(pic));
for(int i = 0; i < n; i++)
{
for(int j = 0; j < m; j++)
{
if(ch[i][j] == '@')
{
dfs(i, j);
}
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: