您的位置:首页 > 其它

HRBUST 2331 Great Atm 尚学堂杯"哈尔滨理工大学第七届程序设计竞赛

2017-05-15 20:13 423 查看
Great Atm
 
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 184(37 users)Total Accepted: 65(32 users)Rating:







Special Judge: No
Description
An old story said the evil dragon wasn’t evil at all, only bewitched, and now that the riddles were solved it was proving to be as kind as its new master.

A powerful warrior Atm is going to solve the riddles. First, he should beat the evil wizard. The road from Atm’s castle to wizard’s lab is filled with magic traps. The magic trap will affect Atm’s combat effectiveness.

Atm’s combat effectiveness can be considered as an integer. Effect of magic trap can be considered as mathematical operation. The three kinds of magic traps correspond to three kind of bit operation. (AND, OR and XOR)

Atm can adjust his equipment to change his initial combat effectiveness from 0 to m (include 0 and m). He wants when he arrives the wizard’s lab, his combat effectiveness can be maximum.
Input
There are multiple test cases.

For each test cases:

The first line contains two integers n(1<=n<=10^5) and m(1<=m<=10^9), indicating the number of magic traps and the maximum of initial combat effectiveness.

Each of the next n lines contains a string and an integer, indicating the bit operation. The string will be “AND”, “OR” or “XOR” correspond to AND operation (&), OR operation (|) or XOR operation (^). The integer t(1<=t<=10^9) is second operand in the operation.

Output
For each test cases, a line contains an integer, indicating
the maximum combat effectiveness when he arrives the wizard's lab.
Sample Input
3 10

AND 5

OR 6

XOR 7
Sample Output
1
Source
"尚学堂杯"哈尔滨理工大学第七届程序设计竞赛
题意是,在0到m之间选一个数,使得其经过n个操作后。得到的值最大。。

经过几次实验后才发现,直接在m,m-1,m-2中找就行。然后取最大值。。。。。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int num[5];
char re[10];
int main()
{
int n,m;
while(~scanf("%d %d",&n,&m))
{

int ls;
memset(num,0,sizeof(num));
for(int i=0; i<=2; i++)
{
num[i]=m-i;
}
for(int i=0; i<n; i++)
{
scanf("%s %d",re,&ls);
if(re[0]=='A')
{
for(int i=0; i<=2; i++)
{
num[i]&=ls;
}
}
else if(re[0]=='X')
{
for(int i=0; i<=2; i++)
{
num[i]^=ls;
}
}
else if(re[0]=='O')
{
for(int i=0; i<=2; i++)
{
num[i]|=ls;
}
}
}
sort(num,num+3);
printf("%d\n",num[2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM
相关文章推荐