您的位置:首页 > Web前端

P1118 [USACO06FEB]数字三角形Backward Digit Su…

2017-05-15 19:25 337 查看

题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

3   1   2   4
4   3   6
7   9
16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个1~N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少1,直到只剩下一个数字位置。下面是一个例子:

3 1 2 4

4 3 6

7 9 16 最后得到16这样一个数字。

现在想要倒着玩这样一个游戏,如果知道N,知道最后得到的数字的大小sum,请你求出最初序列a[i],为1~N的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,9[/color]

输入输出格式

输入格式:

两个正整数n,sum。

输出格式:

输出包括1行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)

输入输出样例

输入样例#1:

4 16


输出样例#1:

3 1 2 4


说明

对于40%的数据,n≤7;

对于80%的数据,n≤10;

对于100%的数据,n≤12,sum≤12345。

杨辉三角+暴力!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int n,num;
const int PT[][13] = //先打一张杨辉三角表
{
{ 1 } , // N = 1
{ 1 , 1 } , // N = 2
{ 1 , 2 , 1 } , // N = 3
{ 1 , 3 , 3 , 1 } , // N = 4
{ 1 , 4 , 6 , 4 , 1 } , // N = 5
{ 1 , 5 , 10, 10, 5 , 1 } , // N = 6
{ 1 , 6 , 15, 20, 15, 6 , 1 } , // N = 7
{ 1 , 7 , 21, 35, 35, 21, 7 , 1 } , // N = 8
{ 1 , 8 , 28, 56, 70, 56, 28, 8 , 1 } , // N = 9
{ 1 , 9 , 36, 84,126,126, 84, 36, 9 , 1 } , // N = 10
{ 1 , 10, 45,120,210,252,210,120, 45, 10 , 1 } , // N = 11
{ 1 , 11, 55,165,330,462,462,330,165, 55 ,11 , 1 } }; // N = 12
int vis[15];
int ans[15];
int flag;
int dfs(int p,int k,int now)//第p个数,值为k,和是now
{

if(now>num)return 0;
if(p==n)
{
if(now==num)
{
ans[p]=k;
return 1;
}
else
return 0;
}
vis[k]=1;
for(int i=1;i<=n;i++)
{
if(vis[i]==0&&dfs(p+1,i,now+PT[n-1][p]*i))
{
ans[p]=k;
return 1;
}
}
vis[k]=0;
return 0;
}
int main()
{

scanf("%d%d",&n,&num);
if(dfs(0,-1,0))
for(int i=1;i<=n;i++)
printf("%d ",ans[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: