您的位置:首页 > 产品设计 > UI/UE

POJ2524--Ubiquitous Religions(并查集)

2017-05-14 23:19 302 查看
Do more with less

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

nput

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9

1 2

1 3

1 4

1 5

1 6

1 7

1 8

1 9

1 10

10 4

2 3

4 5

4 8

5 8

0 0

Sample Output

Case 1: 1

Case 2: 7

思路

一道并查集的题目,关键是要找到它的根节点。有N个人,先初始化数组是的值为数组的下标。

然后在输入每两个人之间的关系,开始更新数组的值,如果两个人的根节点的值相同,则不需要变化,如果不同,将第二个人的根节点的值更新为第一个根节点的值,只需要更新根节点,其他的子节点不需要更新。

代码

#include<cstdio>
int father[50005],sum;
int find(int x)
{
if(father[x]!=x)
father[x]=find(father[x]);
return father[x];
}
void make(int a,int b)
{
int root1=find(a);
int root2=find(b);
if(root1!=root2)
{
father[root2]=root1;
sum--;
}
}
int main()
{
int h=1;
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)break;
for(int k = 1;k <= n;k ++)
father[k] = k ;
sum=n;
for(int k = 1;k <= m;k ++)
{
int i,j;
scanf("%d %d",&i,&j);
make(i,j);
}
//    for(int k = 1; k <= n; k ++)
//        printf("%d   ",father[k]);
printf("Case %d: %d\n",h++,sum);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: