您的位置:首页 > 产品设计 > UI/UE

POJ1458--Common Subsequence(dp)

2017-05-14 22:02 411 查看
Do more with less

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab

programming contest

abcd mnp

Sample Output

4

2

0

思路

最长公共子序列。

二维数组

公式为 :

if(a[i] == b[j])

dp[i+1][j+1] = dp[i][j] + 1;

else

dp[i+1][j+1] = max(dp[i][j+1],dp[i+1][j]);

解读一下公式: 如果两个字符串的地N个字符相同,当前状态相当于前N-1个字符的最长公共子序列+1,如果两个字符串的第N个字符不相同,则当前状态为a串的前N个字符和b串前N-1个字符的最长公共子序列和b串的前N个字符和a串前N-1个字符的最长公共子序列的最大值。

代码

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int dp[1100][1100];
void common(int n,int m,char a[],char b[])
{
for(int i = 0; i < n; i ++)
{
for(int j = 0; j < m; j ++)
{
if(a[i] == b[j])
dp[i+1][j+1] = dp[i][j] + 1;
else
dp[i+1][j+1] = max(dp[i][j+1],dp[i+1][j]);
}
}
printf("%d\n",dp
[m]);
}
int main()
{
int n,m;
char a[1100];
char b[1100];
while(~scanf("%s %s",a,b))
{
memset(dp,0,sizeof(dp));
n = strlen(a);
m = strlen(b);
common(m,n,b,a);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: