您的位置:首页 > 其它

Poj 2955 brackets(区间dp)

2017-05-13 16:45 211 查看
Brackets

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7795Accepted: 4136
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,

if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and

if a and b are regular brackets sequences, then ab is a regular brackets sequence.

no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:


(), [], (()), ()[], ()[()]



while the following character sequences are not:


(, ], )(, ([)], ([(]



Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence
([([]])]
, the longest regular brackets subsequence is
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters
(
,
)
,
[
, and
]
; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

Stanford Local 2004

题解:
f[i][j]表示i到j的最大括号匹配数

#include <iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<deque>
#include<algorithm>
#include<string>
#include<stack>
#include<cmath>
using namespace std;
char ch[105];
int dp[105][105];
int n;
bool ok(int x,int y)
{
if (ch[x]=='(' && ch[y]==')') return 1;
if (ch[x]=='[' && ch[y]==']') return 1;
return 0;
}

int main()
{
while(~scanf("%s",&ch))
{
if (ch[0]=='e') break;
n=strlen(ch);
memset(dp,0,sizeof(dp));
//   for(int i=0;i<n;i++)
//  for(int j=i+1;j<n;j++)  正就是不对的
for(int i=n-1;i>=0;i--)
for(int j=i+1;j<n;j++)
{
if (ok(i,j)) dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
for(int k=i;k<=j;k++)
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);

}
printf("%d\n",dp[0][n-1]);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: