您的位置:首页 > 其它

poj1426

2017-05-12 21:38 127 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31262 Accepted: 13006 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111


题目大意:现在给你一个数,要求输出它的倍数中只含有0和1的数。

题目分析:这题目就是一个坑,看到给的输出数据,以为数据会很大,于是一直在用string存储,发现一直在超内存,然后后来改成了long long就ac了。题目直接用BFS可以做,首先先存入一个1,因为数的第一位只能是1,后面压入队列的就有两种情况了,一个是之前的10倍,一个是之前的10倍加1,这样就把所有的含有0,1的数都压入了队列中。然后遇到是n倍数的输出即可。

代码:
#include <iostream>
#include <queue>

using namespace std;
queue<long long>que;
int main()
{
int n;
while(cin>>n&&n)
{
while(!que.empty())
{
que.pop();
}
long long m=1;
que.push(m);
while(!que.empty())
{
m=que.front();
que.pop();
if(m%n==0){
cout<<m<<endl;
break;
}
que.push(m*10);
que.push(m*10+1);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm BFS poj1426