您的位置:首页 > 其它

NYOJ927 The partial sum problem(DFS)

2017-05-12 21:03 369 查看
The partial sum problem

时间限制:1000 ms | 内存限制:65535 KB

难度:2

描述

One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K.

输入

There are multiple test cases.

Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents Ai.The third line contains an integer K(-10^8≤K≤10^8).

输出

If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.

样例输入

4

1 2 4 7

13

4

1 2 4 7

15

样例输出

Of course,I can!

Sorry,I can’t!

#include<stdio.h>

int n,k,a[25];

int dfs(int i,int sum)
{
if(i==n) return sum==k;//终止条件:如果相等就返回1说明找到了,如果不等返回0则继续找
if(dfs(i+1,sum+a[i])) return 1;//选择a[i]
if(dfs(i+1,sum)) return 1;//不选择a[i]
return 0;//两种情况都没有找到那么就是没有找到
}

int main()
{
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&k);
if(dfs(0,0)) printf("Of course,I can!\n");
else printf("Sorry,I can't!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: