您的位置:首页 > 编程语言 > C语言/C++

hdu 2614 BEAT 回溯的dfs

2017-05-11 20:04 465 查看
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve 
 a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one. 
 You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve. 
InputThe input contains multiple test cases. 
Each test case include, first one integer n ( 2< n < 15).express the number of problem. 
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j. 
OutputFor each test case output the maximum number of problem zty can solved. 

Sample Input
3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0

Sample Output
3
2
4


Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute.
So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0.
But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01.
So zty can choose solve the problem 2 second, than solve the problem 1.



//http://blog.csdn.net/libin56842/article/details/41909429
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1001;
int ans=0;
int n;
int mp[maxn][maxn];
int vis[maxn];
void dfs(int pos,int len,int tm){
ans=max(len,ans);
if(len==n)
return;
for(int i=1;i<=n;i++){
if(!vis[i]&&mp[pos][i]>=tm){
vis[i]=1;
dfs(i,len+1,mp[pos][i]);
vis[i]=0;
}
}
}
int main(){
while(cin>>n){
ans=0;
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
cin>>mp[i][j];
vis[1]=1;
dfs(1,1,0);
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++ dfs 蓝桥 搜索