您的位置:首页 > 其它

POJ 2739 Sum of Consecutive Prime Numbers

2017-05-11 19:51 288 查看
Sum of Consecutive Prime Numbers

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 25126 Accepted: 13698

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.

Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2

3

17

41

20

666

12

53

0

Sample Output

1

1

2

3

0

0

1

2

题意:一个数用连续素数和表示,有几种?

题解:先打素数表,再尺取法

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 10005;
int a[maxn];
int n;
bool is_prime(int num)
{
if(num==2||num == 3) return true;
for(int i=2;i*i<=num;i++)
{
if(num%i==0)
return false;
}
return true;
}
void get_prime()
{
int j=0;
for(int i=2;i<10000;i++)
if(is_prime(i))
a[j++]=i;
}
int chiqu()
{
int i=0;
int j=0;
int sum=0;
int res=0;
while(1)
{
while(a[j]<=n&&sum<n)
sum+=a[j++];
if(sum==n)
res++;
else if(sum<=0)
break;
sum -=a[i++];
}
return res;
}
int main()
{
get_prime();
while(cin>>n&&n)
{
cout<<chiqu()<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: