您的位置:首页 > 其它

POJ3320_Jessica's Reading Problem_尺取法

2017-05-10 17:24 288 查看
Jessica's Reading Problem

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12281 Accepted: 4173
Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text
book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains
all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous
part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what
the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1

Sample Output
2


一本书的每一页上都有一个知识点,不同页上的知识点可能相同。问最少看连续的多少页才能看到全部的知识点。

作为尺取法的模板题整理,有一个注意点见注释。

#include<cstdio>
#include<iostream>
#include<map>
#include<set>

using namespace std;
const int maxn = 1000000;
int a[maxn + 10];

int main ()
{

int n;
cin >> n;

set<int> S;
for(int i= 0; i< n; i++){
scanf("%d", a+i);
S.insert(a[i]);
}
int k = S.size();

map<int, int> M;
int s = 0, t = 0, now = 0, ans = n;

while(t < n){

while(t < n && now < k){
if(M[a[t]] == 0) now ++;
M[a[t]] ++;
t ++;
}

while(s < t && now >= k){

//敲黑板
//在缩小区间的过程中更新 ans
//把自己坑死的 WA点
if(ans > t - s) ans = t - s;

M[a[s]] --;
if(M[a[s]] == 0) now --;
s ++;
}

}

cout << ans << endl;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: