您的位置:首页 > 编程语言 > C语言/C++

Problem : 平面上的点和线——Point类、Line类 (III)

2017-05-09 15:29 267 查看

话不多说,先上题目为敬~

Problem C: 平面上的点和线——Point类、Line类 (III)

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 5456  Solved: 2584

[Submit][Status][Web
Board]

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。

根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。

接口描述:
Point::show()方法:按格式输出Point对象。
Line::show()方法:按格式输出Line对象。

Input

输入的第一行为N,表示后面有N行测试样例。每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。

C语言的输入输出被禁用。

Sample Input

40,0 1,11,1 2,32,3 4,50,1 1,0

Sample Output

Point : (1, -2) is created.Point : (2, -1) is created.Point : (0, 0) is created.Point : (0, 0)=========================Point : (0, 0) is created.Point
: (1, 1) is created.Line : (0, 0) to (1, 1) is created.Line : (0, 0) to (1, 1)Line : (0, 0) to (1, 1) is erased.Point : (1, 1) is erased.Point : (0, 0) is erased.=========================Point : (1, 1) is created.Point : (2, 3) is created.Line : (1, 1) to
(2, 3) is created.Line : (1, 1) to (2, 3)Line : (1, 1) to (2, 3) is erased.Point : (2, 3) is erased.Point : (1, 1) is erased.=========================Point : (2, 3) is created.Point : (4, 5) is created.Line : (2, 3) to (4, 5) is created.Line : (2, 3) to (4,
5)Line : (2, 3) to (4, 5) is erased.Point : (4, 5) is erased.Point : (2, 3) is erased.=========================Point : (0, 1) is created.Point : (1, 0) is created.Line : (0, 1) to (1, 0) is created.Line : (0, 1) to (1, 0)Line : (0, 1) to (1, 0) is erased.Point
: (1, 0) is erased.Point : (0, 1) is erased.=========================Point : (1, -2) is copied.Point : (2, -1) is copied.Line : (1, -2) to (2, -1) is created.Point : (1, -2) is copied.Point : (0, 0) is copied.Line : (1, -2) to (0, 0) is created.Point : (2,
-1) is copied.Point : (0, 0) is copied.Line : (2, -1) to (0, 0) is created.Point : (0, 0) is copied.Point : (2, -1) is copied.Line : (0, 0) to (2, -1) is created.Line : (1, -2) to (2, -1)Line : (1, -2) to (0, 0)Line : (2, -1) to (0, 0)Line : (0, 0) to (2,
-1)Line : (0, 0) to (2, -1) is erased.Point : (2, -1) is erased.Point : (0, 0) is erased.Line : (2, -1) to (0, 0) is erased.Point : (0, 0) is erased.Point : (2, -1) is erased.Line : (1, -2) to (0, 0) is erased.Point : (0, 0) is erased.Point : (1, -2) is erased.Line
: (1, -2) to (2, -1) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.Point : (0, 0) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.

HINT

Append Code

append.cc,

append.cc中的内容为 

int main()
{
char c;
int num, i;
double x1, x2, y1, y2;
Point p(1, -2), q(2, -1), t;
t.show();
std::cin>>num;
for(i = 1; i <= num; i++)
{
std::cout<<"=========================\n";
std::cin>>x1>>c>>y1>>x2>>c>>y2;
Line line(x1, y1, x2, y2);
line.show();
}
std::cout<<"=========================\n";
Line l1(p, q), l2(p, t), l3(q, t), l4(t, q);
l1.show();
l2.show();
l3.show();
l4.show();
}
题目并不难,只要掌握好类中构造,拷贝,析构等函数的调用就好。

依然是 盯瞎了眼的输出~~~

答案如下~

#include <iostream>
using namespace std;
#include <iomanip>
class Point{
private:
double x_,y_;
friend class Line;
public:
Point(double x,double y)
{
x_ = x;
y_ = y;
cout<<"Point : ("<<x_<<", "<<y_<<") is created."<<endl;
}
Point()
{
x_ = 0;
y_ = 0;
cout<<"Point : ("<<x_<<", "<<y_<<") is created."<<endl;
}
void setvalue(double xx,double yy)
{
x_ = xx;
y_ = yy;
}
void setx(int xx) {x_ = xx;}
void sety(int yy) {y_ = yy;}
void show()
{
cout<<"Point : ("<<x_<
4000
;<", "<<y_<<")"<<endl;
}
int x() { return x_;}
int y() { return y_;}
Point(const Point &p)
{
x_ = p.x_;
y_ = p.y_;
cout<<"Point : ("<<x_<<", "<<y_<<") is copied."<<endl;
}
~Point()
{
cout<<"Point : ("<<x_<<", "<<y_<<") is erased."<<endl;
}
};

class Line{
private:
Point x1_,y1_;
double x1,y1,x2,y2;
friend class Point;
public:
Line(double xx1,double yy1,double xx2,double yy2):x1_(xx1,yy1),y1_(xx2,yy2)
{
cout<<"Line : ("<<x1_.x_<<", "<<x1_.y_<<") to ("<<y1_.x_<<", "<<y1_.y_<<") is created."<<endl;
}
Line(Point &q1,Point &q2):x1_(q1),y1_(q2)
{
cout<<"Line : ("<<x1_.x_<<", "<<x1_.y_<<") to ("<<y1_.x_<<", "<<y1_.y_<<") is created."<<endl;
}
void show()
{
cout<<"Line : ("<<x1_.x_<<", "<<x1_.y_<<") to ("<<y1_.x_<<", "<<y1_.y_<<")"<<endl;
}
~Line()
{
cout<<"Line : ("<<x1_.x_<<", "<<x1_.y_<<") to ("<<y1_.x_<<", "<<y1_.y_<<") is erased."<<endl;
}
};

int main() { char c; int num, i; double x1, x2, y1, y2; Point p(1, -2), q(2, -1), t; t.show(); std::cin>>num; for(i = 1; i <= num; i++) { std::cout<<"=========================\n"; std::cin>>x1>>c>>y1>>x2>>c>>y2; Line line(x1, y1, x2, y2); line.show(); } std::cout<<"=========================\n"; Line l1(p, q), l2(p, t), l3(q, t), l4(t, q); l1.show(); l2.show(); l3.show(); l4.show(); }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 类与封装 基础