您的位置:首页 > Web前端

[poj1821] Fence DP单调队列优化

2017-05-08 11:26 288 查看

Fence

Description

A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct.

Being the team’s leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income.

Write a program that determines the total maximal income obtained by the K workers.

Input

The input contains:

Input

N K

L1 P1 S1

L2 P2 S2



LK PK SK

Semnification

N -the number of the planks; K ? the number of the workers

Li -the maximal number of planks that can be painted by worker i

Pi -the sum received by worker i for a painted plank

Si -the plank in front of which sits the worker i

Output

The output contains a single integer, the total maximal income.

Sample Input

8 4

3 2 2

3 2 3

3 3 5

1 1 7

Sample Output

17

Hint

Explanation of the sample:

the worker 1 paints the interval [1, 2];

the worker 2 paints the interval [3, 4];

the worker 3 paints the interval [5, 7];

the worker 4 does not paint any plank

Source

Romania OI 2002

f[i][j]表示前i个人,涂到j的最大值

f[i][j] = max(f[i][j - 1], f[i - 1][j])

f[i][j] = max(f[i][j], f[i - 1][k] + (j - k) * p[i]);

f[i-1][k]+p[i]*(j-k)=(f[i-1][k]-p[i]*k)+p[i]*j

那么就构造递减的单调队列维护k值。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 16000 + 5;
int f[105]
;
struct nd{
int l,p,s;
}pp[105];
bool cmp( nd a, nd b ){ return a.s < b.s; }
int n,k;
int q
;
int main(){
scanf("%d%d", &n, &k);
for( int i = 1; i <= k; i++ ) scanf("%d%d%d", &pp[i].l, &pp[i].p, &pp[i].s );
std::sort( pp+1, pp+k+1, cmp );
for( int i = 1; i <= k; i++ ){
int head = 0,tail = 0;
q[0] = max( pp[i].s - pp[i].l, 0 );
for( int j = 1; j <= n; j++ ){
f[i][j] = max( f[i-1][j], f[i][j-1] );
if( j >= pp[i].l + pp[i].s ) continue;
while( head <= tail && q[head] + pp[i].l < j ) head++;
if( j < pp[i].s ){
while( head <= tail && f[i-1][q[tail]] - q[tail]*pp[i].p < f[i-1][j] - j*pp[i].p) tail--;
q[++tail] = j;
continue;
}
f[i][j] = max( f[i][j], f[i-1][q[head]] + pp[i].p*(j-q[head]));

}
}
printf("%d", f[k]
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: