您的位置:首页 > 编程语言

[编程之美-10]字符串的包含问题

2017-05-07 22:30 232 查看
[题目描述] 给定一长字符串 a 和一段字符串 b 。请问, 如何最快的判断出短字符串 b 中的所有字符是否都在长字符串 a 中。

[Sample Input]

ABCD BAD

ABCD BCE

ABCD AA

[Sample Output]

true

false

true

基本解法:我们遍历字符串b,依次判断b中的每个字符是不是的都在字符串a中。

代码如下:

#include<iostream>
#include<string>
using namespace std;

bool stringContain(string &a, string &b);

int main()
{
string a, b;
while(cin>>a>>b)
{
if(stringContain(a, b))
cout<< "true" << endl;
else
cout<< "false" << endl;
}
return 0;
}

bool stringContain(string &a, string &b)
{
for(int i = 0; i < b.length(); i ++)
{
if(a.find(b[i]) > b.length())
return false;
}
return true;
}


时间复杂度:O(m*n), 空间复杂度:O(1)

高效算法:思考角度,我们都知道ASCII码一共有127个,而题目所说的字符串都是由ASCII码组合而成。首先遍历字符串a,将a中每个字符转化为int类型(作为数组角码)。并开辟数组大小为128的bool类型count数组。count[a[i]] = true.接着去遍历字符串b,依次判断每个字符是否count[b[i]] == true.

#include<iostream>
#include<string>
#include<string.h>
using namespace std;

bool stringContain(string &a, string &b);

int main()
{
string a, b;
while(cin>>a>>b)
{
if(stringContain(a, b))
cout<< "true" << endl;
else
cout<< "false" << endl;
}
return 0;
}

bool stringContain(string &a, string &b)
{
bool count[128];
memset(count, false, sizeof(count));

for(int i = 0; i < a.length(); i ++)
{
count[a[i]] = true;
}

for(int i = 0; i < b.length(); i ++)
{
if(count[b[i]] == false)
return false;
}
return true;
}


时间复杂度:O(m+n), 空间复杂度:128B
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  编程之美