您的位置:首页 > 其它

HDU 6027 Easy Summation

2017-05-07 21:08 429 查看

Easy Summation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 54    Accepted Submission(s): 32


[align=left]Problem Description[/align]
You are encountered with a traditional problem concerning the sums of powers.

Given two integers n
and k.
Let f(i)=ik,
please evaluate the sum f(1)+f(2)+...+f(n).
The problem is simple as it looks, apart from the value of
n
in this question is quite large.

Can you figure the answer out? Since the answer may be too large, please output the answer modulo109+7.
 

[align=left]Input[/align]
The first line of the input contains an integer
T(1≤T≤20),
denoting the number of test cases.

Each of the following T
lines contains two integers n(1≤n≤10000)
and k(0≤k≤5).

 

[align=left]Output[/align]
For each test case, print a single line containing an integer modulo109+7.
 

[align=left]Sample Input[/align]

3
2 5
4 2
4 1

 

[align=left]Sample Output[/align]

33
30
10

题意:给出n,k,求n以内的所有数的k次方之和。对1000000007取模。

很简单直接照着算,不会超时的。

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 1000000007
using namespace std;
int main()
{
int i,j,n,t,a,b;
__int64 s,sum;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&a,&b);
sum=0;
for(i=1;i<=a;i++)
{
s=1;
for(j=0;j<b;j++)
{
s*=i;
if(s>N)
s=s%N;
}
sum+=s;
if(sum>N)
sum=sum%N;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: