您的位置:首页 > 产品设计 > UI/UE

Coprime Sequence(优化)

2017-05-07 19:03 344 查看
Coprime Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 22 Accepted Submission(s): 17

Problem Description

Do you know what is called
Coprime Sequence''? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
Coprime Sequence” is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.

Then the following line consists of n integers a1,a2,…,an(1≤ai≤109), denoting the elements in the sequence.

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input

3

3

1 1 1

5

2 2 2 3 2

4

1 2 4 8

Sample Output

1

2

2

Source

2017中国大学生程序设计竞赛 - 女生专场

Recommend

jiangzijing2015 | We have carefully selected several similar problems for you: 6032 6031 6030 6029 6028

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<string>
#include<iomanip>
#include<cmath>
#define ll long long int
#define maxsize 105000
#define INF  99999999
using namespace std;
ll a[100010];
ll yu[maxsize];
ll yv[maxsize];
ll gcd(ll x, ll y)
{
if (x > y)
{
int k;
k = y;
y = x;
x = k;
}
ll c;
c = y%x;
if (c == 0)
return x;
else
{
gcd(c, x);
}
}
int main()
{
int t;
int n;
while (cin >> t)
{
while (t--)
{
cin >> n;
int min1;
memset(yu, 0, sizeof(yu));
memset(yv, 0, sizeof(yv));
for (int i = 1;i <= n;i++)
{
cin >> a[i];
}
yu[1] = a[1];
yu[0] = INF;//重点!
for (int i = 2;i <= n;i++)//正向gcd
{
yu[i] = gcd(yu[i - 1], a[i]);

}
yv
= a
;
yu[n + 1] = INF;//重点!
for (int i = n - 1;i >0;i--)//反向gcd
{
yv[i] = gcd(a[i], yv[i + 1]);
}
for (int i = 1;i <=n;i++)//寻找最小点并删除
{
if (yu[i] == yv[i])
{
min1 = i;
break;
}
}

cout << min(yu[min1 - 1], yv[min1 + 1]) << endl;

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: