您的位置:首页 > 其它

HDU 1050 Moving Tables (两种思路)

2017-05-07 18:54 411 查看


Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35145    Accepted Submission(s): 11559


Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

 

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains
two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

 

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

 

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

 

Sample Output

10
20
30

 

Source

Asia 2001, Taejon (South Korea)

方法一:

这是几百年前WJL告诉我的方法:开一个数组记录次数,最大的便是。

[html] view
plain copy

#include <iostream>  

#include <stdio.h>  

#include <string.h>  

#include <algorithm>  

#include <math.h>  

using namespace std;  

const int N = 406;  

int main()  

{  

    int T;  

    scanf("%d",&T);  

    while(T--)  

    {  

  

        int n;  

        scanf("%d",&n);  

        int ans=0;  

        int flag
;  

        int a,b;  

        memset(flag,0,sizeof flag);  

        for(int i=1;i<=n;i++)  

        {  

            scanf("%d %d",&a,&b);  

            if(a>b) swap(a,b);  

            if(a%2==0) a--;  

            if(b%2==1) b++;  

            for(int j=a;j<=b;j++)  

            {  

                flag[j]++;  

                if(ans<flag[j]) ans=flag[j];  

            }  

        }  

        printf("%d\n",ans*10);  

    }  

  

    return 0;  

}  

方法二:

自己想的,反复贪心,写起来很麻烦。思路就是运行N次的“今年暑假不AC”那题,N×10就是答案。

[html] view
plain copy

#include <iostream>  

#include <stdio.h>  

#include <algorithm>  

#include <queue>  

#include <string.h>  

using namespace std;  

struct node  

{  

    int be;  

    int end;  

}a[202];  

bool cmd(node a,node b)  

{  

    return a.be< b.be;  

}  

int main()  

{  

    int t;  

    while(~scanf("%d",&t))  

    {  

        while(t--)  

        {  

            int n;  

            scanf("%d",&n);  

            memset(a,0,sizeof a);  

            for(int i=1;i<=n;i++)  

            {  

                scanf("%d %d",&a[i].be,&a[i].end);  

                if(a[i].be>a[i].end) swap(a[i].be,a[i].end);  

                if(a[i].be%2==0) a[i].be--;  

                if(a[i].end%2==1) a[i].end++;  

            }  

            int flag[202];  

            memset(flag,0,sizeof flag);  

            sort(a+1,a+1+n,cmd);  

            int i;  

            int begin;  

            for(i=0;;i++)  

            {  

                begin=0;  

                int q=0;  

                for(int j=1;j<=n;j++)  

                {  

                    if(flag[j])  

                        continue;  

                    q++;  

                    if(begin<=a[j].be)  

                    {  

                        begin=a[j].end;  

                        flag[j]=1;  

                    }  

                }  

                if(q==0)  

                {  

                 //   printf("1");  

                    break;  

                }  

            }  

            printf("%d\n",i*10);  

        }  

    }  

  

    return 0;  

}  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: