您的位置:首页 > 产品设计 > UI/UE

杭电1242-Rescue-DFS

2017-05-07 17:36 169 查看

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30278    Accepted Submission(s): 10652


[align=left]Problem Description[/align]Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 
[align=left]Input[/align]First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 
[align=left]Output[/align]For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 
[align=left]Sample Input[/align]
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

 

[align=left]Sample Output[/align]

13

思路:

1.天使可能有多个朋友,所以不能从朋友的位置开始着天使,只能是从天使找离他最近的朋友

2.题目要求的是找到一个用时最少的朋友,而不是步数最少

#include<stdio.h>
int d[4][2]={0,1,0,-1,1,0,-1,0},p,n,m;
char a[310][310],b[310][310];
void dfs(int x,int y,int s)
{
int i,tx,ty;
if(a[x][y]=='r')
{
if(s<p)p=s;
return;
}
for(i=0;i<4;i++)
{
tx=x+d[i][0];
ty=y+d[i][1];
if(tx<0||tx>=n||ty<0||ty>=m||b[tx][ty]||a[tx][ty]=='#')continue;
b[tx][ty]=1;
if(a[tx][ty]=='x')dfs(tx,ty,s+2);
else dfs(tx,ty,s+1);
b[tx][ty]=0;
}
}
int main()
{
int sx,sy,i,j;
while(~scanf("%d%d",&n,&m))
{
getchar();
memset(b,0,sizeof(b));
for(i=0;i<n;i++)
gets(a[i]);
for(i=0;i<n;i++)
for(j=0;j<m;j++)
if(a[i][j]=='a')
{
sx=i;
sy=j;
b[sx][sy]=1;
break;
}
p=99999;
dfs(sx,sy,0);
if(p==99999)
puts("Poor ANGEL has to stay in the prison all his life.");
else
printf("%d\n",p);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: