您的位置:首页 > 其它

HDU 3449 Consumer (依赖背包)

2017-05-07 16:49 369 查看


Consumer


Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/65536K (Java/Other)


Total Submission(s) : 10   Accepted Submission(s) : 8


Font: Times New Roman | Verdana | Georgia


Font Size: ← →


Problem Description

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy
the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.


Input

The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number
goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)


Output

For each
4000
test case, output the maximum value FJ can get


Sample Input

3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60



Sample Output

210



Source

2010 ACM-ICPC Multi-University Training Contest(2)——Host by BUPT

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
int dp[52][100200];

int main()
{
int n,m;
while(~scanf("%d %d",&n,&m))
{
memset(dp,0,sizeof dp);
for(int i=1;i<=n;i++)
{
int p,num;
scanf("%d %d",&p,&num);
int temp[100200];
memset(temp,0,sizeof temp);
for(int j=p;j<=m;j++)
{
temp[j]=dp[i-1][j-p];
}
while(num--)
{
int cj,pj,w,val;
scanf("%d %d",&w,&val);
for(int j=m;j>=w;j--)
{
if(j-p-w>=0)//得买得起
temp[j]=max(temp[j],temp[j-w]+val);
}
for(int j=m;j>=0;j--)
{
dp[i][j]=max(temp[j],dp[i-1][j]);//买ibox或不买
}
}
}
printf("%d\n",dp
[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: