您的位置:首页 > 编程语言 > C语言/C++

杭电ACM刷题(1):1002,A + B Problem II 标签: acmc语言 2017-05-07 15:35 139人阅读 评

2017-05-07 15:35 381 查看

最近忙于考试复习,没有多少可供自己安排的时间,所以我利用复习之余的空闲时间去刷刷杭电acm的题目,也当对自己编程能力的锻炼吧。

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

程序思路:

  1. 使用scanf函数以字符串格式接收两个数,分别存在两个数组中,数组中每一个成员对应数的一位(0-9);
  2. 由于数组中存放的是每个数字对应的ASCII码,所以将其减去0得到十进制的数值;
  3. 对比连个数组的长度,如果长度不等,就补0,使其在做加法时位数能够对齐;考虑到有可能两个数的最高位相加后有进位,所以两个数组都再额外多补充一位的0;
  4. 随后可以加一个for循环,将两个数组的所有对应位相加,对于每一位,如果和大于等于10,就进位,即下一位加1,当前为减10;
  5. 输出得到的结果。

程序:

#include "stdio.h"
#include "string.h"

#pragma warning(disable:4996)

int main()
{
char a_str[1000] = { 0 }, b_str[1000] = {0};
int a_num[1000], b_num[1000];
int a_len, b_len, max_len;
int n;
int i, j, k;
int temp;

scanf("%d", &n);
if (n < 1 || n>20)
return -1;

for (i = 1;i <= n;i++)
{
//步骤1
scanf("%s%s", a_str, b_str);
a_len = strlen(a_str);
b_len = strlen(b_str);

//步骤2
temp = 0;
for (j = a_len - 1;j >= 0;j--)
{
a_num[temp++] = a_str[j] - '0';
}

temp = 0;
for (k = b_len - 1;k >= 0;k--)
{
b_num[temp++] = b_str[k] - '0';
}

//步骤3
if (a_len > b_len)
{
for (j = b_len;j <= a_len;j++)
{
b_num[j] = 0;
}
a_num[a_len] = 0;
}
else if (a_len < b_len)
{
for (j = a_len;j <= b_len;j++)
{
a_num[j] = 0;
}
b_num[b_len] = 0;
}
else
{
a_num[a_len] = 0;
b_num[b_len] = 0;
}

max_len = (a_len >= b_len) ? a_len : b_len;

//步骤4
for (j = 0;j <= max_len;j++)
{
a_num[j] += b_num[j];
if (a_num[j] >= 10)
{
a_num[j] -= 10;
a_num[j + 1] += 1;
}
}

//步骤5
printf("Case %d:\n", i);
printf("%s + %s = ", a_str, b_str);
if (a_num[max_len] == 0)
{
for (j = max_len - 1;j >= 0;j--)
printf("%d", a_num[j]);
}
else
{
for (j = max_len;j >= 0;j--)
printf("%d", a_num[j]);
}

if (i != n)
printf("\n\n");
else
printf("\n");
}

return 0;
}

备注:
由于我是在visual studio 2015环境中调试这段程序的,在使用“scanf”函数时会报错。因为在microsoft的Visual Studio进行编译时,会提示“scanf”函数是不安全的,建议使用“scanf_s”函数来代替“scanf”。“scanf_s”函数在使用时,如果需要输入字符串数组,还需要指定边界,即数组的长度。一般情况下使用“scanf_s”函数就能替代“scanf”函数了,但是这题中却不行,因为我们也无法确定输入数组的长度。所以得出的结论就是,继续使用“scanf”函数,在程序加入这段代码:

#pragma warning(disable:4996)

这样就可以照常在程序中使用“scanf”而不报错了。

运行结果:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: