您的位置:首页 > 其它

HDU 2602 Bone Collector(01背包裸题)

2017-05-07 00:21 477 查看

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 60469 Accepted Submission(s): 25209

[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


[align=left]Input[/align]
The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1

[align=left]Sample Output[/align]

14

[align=left]Author[/align]
Teddy

[align=left]Source[/align]
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602

意:一个叫做Bone Collector的男的有一个包,往包里放东西,使得其价值最大。

输入:注意是先输入的是价值,后是体积。

分析:01背包裸题,注意格式输入输出就行了,我就是输入格式写错了,找错误找了一个小时,QAQ

下面给出AC代码:

#include <bits/stdc++.h>
using namespace std;
int main()
{
int n;
int v[1010],dp[1010],d[1010];//v代表体积,d代表谷歌值
while(scanf("%d",&n)!=EOF)
{
while(n--)
{
memset(v,0,sizeof(v));
memset(dp,0,sizeof(dp));
memset(d,0,sizeof(d));
int x,y;
cin>>x>>y;
for(int i=1;i<=x;i++)
cin>>d[i];
for(int i=1;i<=x;i++)
cin>>v[i];
for(int i=1;i<=x;i++)//01背包主函数
{
for(int j=y;j>=v[i];j--)
{
dp[j]=max(dp[j],dp[j-v[i]]+d[i]);
}
}
printf("%d\n",dp[y]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: