您的位置:首页 > 其它

HDU 5978 Convex(几何水题)

2017-05-04 10:41 369 查看


Convex

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 683    Accepted Submission(s): 449


Problem Description

We have a special convex that all points have the same distance to origin point.

As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.

Now give you the data about the angle, please calculate the area of the convex

 

Input

There are multiple test cases.

The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)

The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.

 

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

 

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

 

Sample Output

2.000
2.598

 

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  6022 6021 6020 6019 6018 

解题思路:

【题意】

二维坐标中有N个点,它们到原点的距离均为D

将这N个点分别与原点相连,现在告诉你任意相邻两条线段的夹角为θi,求这N个点构成的凸包面积(N边形面积)

【类型】

三角形面积水题

【分析】

题目大概样子如下



由图可知,n边形的面积可以拆分成n个三角形面积之和

而已知每个三角形的两边及两边夹角,我们可以通过三角形面积公式

算出每个三角形的面积,相加之和便是最终的n边形面积



由于math.h头文件中封装的sin运算是以弧度制来计算的,而题目所给的是角度制,故我们还需多一步角度转弧度  S=absin(夹角)/2

其实很简单的好不好,就是当时敲的时候把PI给忘了乘

#include<bits/stdc++.h>
using namespace std;

int main()
{
int n,len,ang;
while(~scanf("%d%d",&n,&len))
{
double sum=0;
for(int i=0;i<n;i++){
scanf("%d",&ang);
sum+=len*len*sin(ang/180.0 * M_PI)*0.5;
}
printf("%.3f\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: