您的位置:首页 > 其它

Codeforces Round #401 (Div. 2)C. Alyona and Spreadsheet(暴力)

2017-05-03 18:19 483 查看
传送门

Description

During the lesson small girl Alyona works with one famous spreadsheet computer program and learns how to edit tables.

Now she has a table filled with integers. The table consists of n rows and m columns. By ai, j we will denote the integer located at the i-th row and the j-th column. We say that the table is sorted in non-decreasing order in the column j if ai, j ≤ ai + 1, j for all i from 1 to n - 1.

Teacher gave Alyona k tasks. For each of the tasks two integers l and r are given and Alyona has to answer the following question: if one keeps the rows from l to r inclusive and deletes all others, will the table be sorted in non-decreasing order in at least one column? Formally, does there exist such j that ai, j ≤ ai + 1, j for all i from l to r - 1 inclusive.

Alyona is too small to deal with this task and asks you to help!

Input

The first line of the input contains two positive integers n and m (1 ≤ n·m ≤ 100 000) — the number of rows and the number of columns in the table respectively. Note that your are given a constraint that bound the product of these two integers, i.e. the number of elements in the table.

Each of the following n lines contains m integers. The j-th integers in the i of these lines stands for ai, j (1 ≤ ai, j ≤ 109).

The next line of the input contains an integer k (1 ≤ k ≤ 100 000) — the number of task that teacher gave to Alyona.

The i-th of the next k lines contains two integers li and ri (1 ≤ li ≤ ri ≤ n).

Output

Print "Yes" to the i-th line of the output if the table consisting of rows from li to ri inclusive is sorted in non-decreasing order in at least one column. Otherwise, print "No".

Sample Input

5 4
1 2 3 5
3 1 3 2
4 5 2 3
5 5 3 2
4 4 3 4
6
1 1
2 5
4 5
3 5
1 3
1 5


Sample Output

Yes
No
Yes
Yes
Yes
No


Note

In the sample, the whole table is not sorted in any column. However, rows 1–3 are sorted in column 1, while rows 4–5 are sorted in column 3.

思路

题意:给定一个nxm的矩阵,然后给出一些询问,在第x行到第y行之间是否存在至少一列的数呈非递减序列。

题解:暴力的求出每列数能往下到达的最大深度,然后记录下每一行可到达的最大深度的值。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 10005;

int main()
{
int n,m,q,l,r;
scanf("%d%d",&n,&m);
int **a = (int **)malloc(n*sizeof(int *));
int **b = (int **)malloc(n*sizeof(int *));
int *len = (int *)malloc(n*sizeof(int));
for (int i = 0;i < n;i++)	a[i] = (int *)malloc(m*sizeof(int)),b[i] = (int *)malloc(m*sizeof(int));

for (int i = 0;i < n;i++)	for (int j = 0;j < m;j++)	scanf("%d",&a[i][j]);
for (int i = 0;i < m;i++)
{
for (int j = 0;j < n;j++)
{
int pos = j;
int cnt = 0;
while (pos + 1< n &&a[pos][i] <= a[pos+1][i])	pos++,cnt++;
for (int k = j;k <= pos;k++)	b[k][i] = pos;
j += cnt;
}
}
for (int i = 0;i < n;i++)
{
len[i] = b[i][0];
for (int j = 1;j < m;j++)
{
len[i] = max(len[i],b[i][j]);
}
}
scanf("%d",&q);
while (q--)
{
scanf("%d%d",&l,&r);
if (len[l-1] >= r - 1)	printf("Yes\n");
else	printf("No\n");
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: