您的位置:首页 > 其它

模拟法(poj 1068)Parencodings

2017-05-03 17:15 330 查看
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:

q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
S		(((()()())))

P-sequence	    4 5 6666

W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line
is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


思路就是先把括号用str表示,然后读取str,如果str[i]是‘)’,则从右向左分别计算 ‘)’   和   '('   的数量,当相等时就停止,此时任意一个的数量就是所包含的括号数
a56f

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;
int n;
int a[25];
int main()
{
int t;
cin>>t;
while(t--)
{
cin>>n;
for(int i=1; i<=n; ++i)
cin>>a[i];
string str="";
int sum=0;
for(int i=1; i<=n; ++i)
{
for(int j=1; j<=a[i]-sum; ++j)
{
str+='(';
}
sum=a[i];
str+=')';
}
int l=str.length();
int cnt=0;
for(int i=0; i<l; ++i)
{
if(str[i]==')')
{
cnt++;
int num1=0;
int num2=0;
for(int j=i; j>=0; --j)
{
if(str[j]=='(')
num2++;
if(str[j]==')')
num1++;
if(num1==num2)
{
if(cnt<n)
cout<<num1<<" ";
else
cout<<num1<<endl;
break;
}
}
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: