您的位置:首页 > 其它

HDOJ 1236 排名

2017-05-03 17:12 369 查看
题目链接:点击打开链接

排名

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23527    Accepted Submission(s): 8609
[/b]

Problem Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑

每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的

考生,并将他们的成绩按降序打印。

 

Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N

< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一

名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号

(题目号由1到M)。

当读入的考生人数为0时,输入结束,该场考试不予处理。

 

Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高

到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考

号的升序输出。

 

Sample Input

4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

 

Sample Output

3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

具体代码实现如下:
package acm;

import java.util.Scanner;

public class P1236 {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
int n=sc.nextInt();//考生人数
if(n==0){
break;
}
int M=sc.nextInt(); //考题数
int a[]=new int[M];
int G=sc.nextInt(); //分数线
int m[]=new int
;//n个学生的解题数
int b[][]=new int
[11];//n个学生的解了的题的题号
for(int i=0;i<M;i++){
a[i]=sc.nextInt();
}
String str[]=new String
;//n个学生的准考证号
for(int i=0;i<n;i++){
str[i]=sc.next();
m[i]=sc.nextInt();
for(int j=1;j<=m[i];j++){
b[i][j]=sc.nextInt();
}
}
int count=0;//分数高于分数线的考生数
String str1[]=new String
;//分数高于分数线的考生准考证号
int c[]=new int
;//n个学生的分数
int c1[]=new int
;//大于分数线的学生的分数
for(int i=0;i<n;i++){
for(int j=1;j<=m[i];j++){
c[i]+=a[b[i][j]-1];
//System.out.print(str[i]+" "+c[i]+"----");
}
//System.out.println(str[i]+" "+c[i]);
if(c[i]>=G){
str1[count]=str[i];
c1[count]=c[i];
count++;
}
}
for(int i=0;i<count;i++){
for(int j=i+1;j<count;j++){
if(c1[i]<c1[j]){//按分数从高到低
int t=c1[i];
c1[i]=c1[j];
c1[j]=t;
String t1=str1[i];
str1[i]=str1[j];
str1[j]=t1;
}
if(c1[i]==c1[j]&&str1[i].compareTo(str1[j])>0){
//分数相等,则按考生号升序输出
int t=c1[i];
c1[i]=c1[j];
c1[j]=t;
String t1=str1[i];
str1[i]=str1[j];
str1[j]=t1;
}
}
}
System.out.println(count);
for(int i=0;i<count;i++){
System.out.println(str1[i]+" "+c1[i]);
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDOJ