您的位置:首页 > 其它

ACM-二分贪心X-24

2017-05-03 16:45 204 查看
(欢迎阅读我的博客,如发现错误或有建议请评论留言,谢谢。)

题目要求:

Description

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing! 

The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever
because he got the highest number of points. 

Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list
of weekly rankings, finds out which player(s) got the second place according to the number of points.

Input

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each
ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume
that: 
in each test case there is exactly one best player and at least one second best player, 

each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.

Output

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers
of all second best players in increasing order. Each identification number produced must be followed by a blank space.

Sample Input

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0


Sample Output

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100


题目思路:

按输入中每个编号出现次数排名,按小到大顺序输出第二名编号。用sort排序即可(需要按次数和序号大小排列一下,次数优先)

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct fun
{
int num;
int s;
};
int cmp(fun a,fun b)
{
if(a.s==b.s)
return a.num<b.num;
else
return a.s>b.s;
}
int main()
{
fun tmp[10001];
int n,m,a,i;
while(scanf("%d%d",&n,&m))
{
memset(tmp,0,sizeof(tmp));
if(n==0&&m==0)break;
for(i=0;i<n*m;i++)
{
scanf("%d",&a);
tmp[a].num=a;
tmp[a].s++;
}
sort(tmp,tmp+10000,cmp);
i=1;
while(tmp[i].s==tmp[i+1].s)
{
printf("%d ",tmp[i].num);
i++;
}
printf("%d\n",tmp[i].num);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: