您的位置:首页 > 其它

ACM-二分贪心R-18

2017-05-03 16:28 232 查看
(欢迎阅读我的博客,如发现错误或有建议请评论留言,谢谢。)

题目如下:

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0


Sample Output

Case 1: 2
Case 2: 1


题目思路:

在海边建立雷达将每个海上的点覆盖到,问需要至少几个雷达才能实现,我们可以把每个点雷达可以放置的范围求出来(左右两个边界),然后再判断需要的雷达数,

有几个情况是不可能实现的:1.雷达覆盖半径小于点到海边的距离,2.雷达覆盖半径小于等于零,3.点到海边距离小于零。

代码如下:

#include<iostream>
#include<cmath>
#include<algorithm>
struct fun
{
double x;
double y;
}a[1001];
struct funs
{
double left;
double right;
}b[1001];
int cmp(funs a,funs b)
{
return a.left<b.left;
}
using namespace std;
int i,n,d,k,m,w,sum;
double tmp,q,e;
int main()
{
w=1;
while(cin>>n>>d)
{
if(n==0&&d==0)break;
sum=1;
for(i=0;i<n;i++)
{
cin>>q>>e;
a[i].x=q;
a[i].y=e;
b[i].left=a[i].x-sqrt(d*d-a[i].y*a[i].y);
b[i].right=a[i].x+sqrt(d*d-a[i].y*a[i].y);
if(a[i].y>d||d<=0||a[i].y<0)sum=-1;
}
sort(b,b+n,cmp);
tmp=b[0].right;
if(sum!=-1)
{
for(i=1;i<n;i++)
{
if(tmp<b[i].left)
{
sum++;
tmp=b[i].right;
}
else if(tmp>b[i].right)
tmp=b[i].right;
}
}
cout<<"Case "<<w++<<": "<<sum<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: