您的位置:首页 > 其它

HDU 2126 Buy the souvenirs

2017-05-03 15:38 316 查看


Buy the souvenirs

Time Limit: 10000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 869 Accepted Submission(s): 298



Problem Description

When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but
also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few.
So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top
coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7),
ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).

Input

For the first line, there is a T means the number cases, then T cases follow.

In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.

All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.

Output

If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can
buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”

Sample Input

2
4 7
1 2 3 4

4 0
1 2 3 4


Sample Output

You have 2 selection(s) to buy with 3 kind(s) of souvenirs.
Sorry, you can't buy anything.


解题思路:算符合条件的方案种数,注意初始化for(i=0;i<m;i++) dp[i][0]=1表示0个物品能够填充随意大小的背包。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Inf 0x7fffffff
using namespace std;
int main()
{
int i,j,k,t,n,m,Min,ans,sum,v[35],dp[505][35];
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
Min=Inf;sum=0;
for(i=0;i<n;i++)
scanf("%d",v+i),Min=min(v[i],Min),sum+=v[i];
if(Min>m)
{
printf("Sorry, you can't buy anything.\n");
continue;
}
if(sum<=m)
{
printf("You have 1 selection(s) to buy with %d kind(s) of souvenirs.\n",n);
continue;
}
sort(v,v+n);
sum=0;
for(i=0;i<n;i++)
{
sum+=v[i];
if(sum>m)
{
ans=i;
break;
}
}
memset(dp,0,sizeof(dp));
for(i=0;i<m;i++)
dp[i][0]=1;
for(i=0;i<n;i++)
for(j=m;j>=v[i];j--)
for(k=ans;k>=0;k--)
dp[j][k]+=dp[j-v[i]][k-1];
printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",dp[m][ans],ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: