您的位置:首页 > 其它

hdu2588——GCD(欧拉函数)

2017-05-02 20:22 316 查看

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2136    Accepted Submission(s): 1087


[align=left]Problem Description[/align]
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.

(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:

Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

[align=left]Input[/align]
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

[align=left]Output[/align]
For each test case,output the answer on a single line.
 

[align=left]Sample Input[/align]

3
1 1
10 2
10000 72

 

[align=left]Sample Output[/align]

1
6
260

 

[align=left]Source[/align]
ECJTU 2009 Spring Contest 

题意大概:给定N,M(2<=N<=1000000000, 1<=M<=N), 求1<=X<=N 且gcd(X,N)>=M的个数。

解法:数据量太大,用常规方法做是行不通的。后来看了别人的解题报告说,先找出N的约数x,

          并且gcd(x,N)>= M,结果为所有N/x的欧拉函数之和。

          因为x是N的约数,所以gcd(x,N)=x >= M;

   设y=N/x,y的欧拉函数为小于y且与y互质的数的个数。

   设与y互质的的数为p1,p2,p3,…,p4

   那么gcd(x* pi,N)= x >= M。

          也就是说只要找出所有符合要求的y的欧拉函数之和就是答案了。
#include<iostream>

#include<cstdio>

#include<cstring>

using namespace std;

typedef long long ll;

int oula(int n)

{

    int res=1,i;

    for(i=2; i*i<=n; i++)

        if(n%i==0)//i是素数

        {

            n/=i;//因为要算ni-1次方,所以在这先除一下

            res*=i-1;

            while(n%i==0)

            {

                n/=i;//n越来越小

                res*=i;

            }

        }

    if(n>1)

        res*=n-1;

    return res;

}

int main()

{

    int i,j,k,t;

    int n,m;

    scanf("%d",&t);

    while(t--){

        scanf("%d%d",&n,&m);

        int ans=0;

        for(i=1;i*i<=n;i++){

            if(n%i==0){

                if(i>=m)ans+=oula(n/i);

                if(n/i>=m&&i!=n/i)ans+=oula(n/(n/i));//注意平方根不能重复算

            }

        }

        printf("%d\n",ans);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: