您的位置:首页 > 其它

HDU1054 Strategic Game(最小顶点覆盖)

2017-05-02 16:48 375 查看


Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8109    Accepted Submission(s): 3875


Problem Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the
minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes

the description of each node in the following format

node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier

or

node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 


 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

 

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

 

Sample Output

1
2

 

Source

Southeastern Europe 2000

 
思路:求二分图的最小顶点覆盖问题,最小顶点覆盖数=最大匹配数;

#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;

int n,vis[1505],link[1505];
vector<int >p[1505];

int find(int x){
for(int i = 0; i < p[x].size(); i ++){
int v = p[x][i];
if(!vis[v]){
vis[v] = 1;
if(link[v] == -1 || find(link[v])){
link[v] = x;
return 1;
}
}
}
return 0;
}

int main(){
while(~scanf("%d",&n)){
int x,y,z;
for(int i = 0; i <= n; i ++)
p[i].clear();

for(int i = 0; i < n; i ++){
scanf("%d:(%d)",&x,&y);
for(int j = 0; j < y; j ++){
scanf("%d",&z);
p[x].push_back(z);
p[z].push_back(x);
}
}

int cnt=0;
memset(link,-1,sizeof(link));
for(int i = 0; i < n; i ++){
memset(vis,0,sizeof(vis));
if(find(i)){
cnt ++;
}
}
printf("%d\n",cnt/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: