您的位置:首页 > 产品设计 > UI/UE

hdu 1005 Number Sequence

2017-05-01 19:30 351 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 170784    Accepted Submission(s): 42133


Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5题目解析:这个题的意思就是要求f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.的值。
题目解析:直接对这个方程用函数或递归直接写出都会导致内存超出,要考虑一下,经过思考后发现,这个题会出现循环,48是他的循环周期,这样这个题就变得很简单了。
代码:
#include<cstdio>
int ans[49];
int main()
{
int A,B,n,i;
while(~scanf("%d%d%d",&A,&B,&n))
{
if(A==0&&B==0&&n==0)
printf("");
else
{
ans[0]=0;
ans[1]=1;
ans[2]=1;
for(i=3; i<=48; i++)
ans[i]=(A*ans[i-1]+B*ans[i-2])%7;

printf("%d\n",ans[n%48]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: