您的位置:首页 > 其它

Meeting Room Arrangement

2017-04-30 16:29 302 查看
Faculty of Engineering of PSU has a large meeting room for faculty staff to organize events and meetings.

The use of the meeting room must be reserved in advance. Since the meeting room is available in 10

hours per day and there may be several events that want to use the meeting room, the best usage policy

is to maximize the number of events in day.

Suppose that the meeting room is available from time 0 to 10 (10 hours). Given the list of start

time and finish time of each candidate event, you are to write a program to select the events that fit in

the meeting room (i.e. their times do not overlap) and give the maximum number of events in a day.

Input

The first line is a positive integer n (1 ≤ n ≤ 100) which determines the number of days (test cases).

Each test case consists of the time of the candidate events (less than 20 events). Each event time

includes 2 integers which are start time(s) and finish time(f), 0 ≤ s ≤ 9, 1 ≤ f ≤ 10 and s < f. The

line containing ‘0 0’ indicates the end of each test case. Note that an event must use at least 1 hour.

Output

For each test case, print out the maximum number of events that can be arranged in the meeting room.

Sample Input

3

0 6

5 7

8 9

5 9

1 2

3 4

0 5

0 0

6 10

5 6

0 3

0 5

3 5

4 5

0 0

1 5

3 9

0 0

Sample Output

4

4
1

题意:给定一段时间,再给出事情的起始时间和结束时间,算出最多可以完成多少事情。

思路:贪心,就是将会议的结束时间,,从小到大排序每次都是选取当前结束最早的会议,将该会议的开始时间与之前的结束时间进行比较,如果可以就将该会议加入

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include<cstring>

using namespace std;

struct node
{
int left;
int right;
}no[500];
bool cmp(node x,node y)
{
if(x.right==y.right)
return x.left<y.left; //如果结束时间相同,比开始时间
else
return x.right<y.right; //比结束时间
}
int main()
{
int icase;
//freopen("e:\\in.txt","r",stdin);
scanf("%d",&icase);
while(icase--)
{
int l,r,i=0;
while(scanf("%d%d",&l,&r)==2){
if(l==0&&r==0)
break;
no[i].left=l;
no[i].right=r;
i++;
}
//输入完成

sort(no,no+i,cmp);
//贪心排序
int cnt=0,judge=0;
for(int j=0;j<i;j++)
{
if(no[j].left>=judge)
{
cnt++;
judge=no[j].right;
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心