您的位置:首页 > 编程语言 > Java开发

杭电oj(java版)—— 1020 Encoding

2017-04-29 15:48 399 查看

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 45511    Accepted Submission(s): 20112


[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

[align=left]Input[/align]
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

[align=left]Output[/align]
For each test case, output the encoded string in a line.

 

[align=left]Sample Input[/align]

2
ABC
ABBCCC

 

[align=left]Sample Output[/align]

ABC
A2B3C

 
import java.util.Scanner;

public class Main{
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int n = scanner.nextInt();

for (int i=0;i<n;i++) {
String s = scanner.next();
String str = "";
int cin = 0;
while (cin<s.length()) {
int sum = 1;
char ch = s.charAt(cin);
while (++cin<s.length()&&ch==s.charAt(cin)) {
sum++;
}
if (sum==1) {
str += ""+ch;
}else {
str += ""+sum+ch;
}
}
System.out.println(str);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: