您的位置:首页 > 其它

NYOJ234吃土豆(双层动态规划)

2017-04-29 10:24 387 查看

吃土豆

时间限制:1000 ms  |  内存限制:65535 KB

难度:4
描述 Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want
to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas
are x-1 and x+1.



Now, how much qualities can you eat and then get ?
输入There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.
输出For each case, you just output the MAX qualities you can eat and then get.样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

样例输出
242


思路:首先找出每一行能吃的最大土豆数,在按照列dp一次就可以找出最大数了

#include<stdio.h>
#include<string.h>
#define max(x,y)(x>y?x:y)
int map[510][510];
int dp[510][510][2];
int maxR[510];
int dp2[510][2];
int main()
{
int m,n,i,j,k;
while(scanf("%d%d",&m,&n)!=EOF)
{
memset(dp,0,sizeof(dp));
memset(dp2,0,sizeof(dp2));
for(i=1;i<=m;i++)
for(j=1;j<=n;j++)
scanf("%d",&map[i][j]);
for(k=1;k<=m;k++)
{
for(i=1;i<=n;i++)
{
dp[k][i][0]=max(dp[k][i-1][0],dp[k][i-1][1]);
dp[k][i][1]=dp[k][i-1][0]+map[k][i];
}
}
for(i=1;i<=m;i++)
maxR[i]=max(dp[i]
[0],dp[i]
[1]);
for(i=1;i<=m;i++)
{
dp2[i][0]=max(dp2[i-1][0],dp2[i-1][1]);
dp2[i][1]=dp2[i-1][0]+maxR[i];
}
int res=max(dp2[m][0],dp2[m][1]);
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划