您的位置:首页 > 其它

PAT-A-1093. Count PAT's (25)

2017-04-28 23:09 417 查看


1093. Count PAT's (25)

时间限制

120 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CAO, Peng

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT

Sample Output:
2

#include<iostream>
#include<cstdio>
#include<string.h>

using namespace std;

char a[100010];

int main()
{
cin >> a;
int numt = 0;
int numat = 0;
int numpat = 0;
int len = strlen(a);
for (int i = len - 1; i >= 0; i--)
{
if (a[i] == 'T')
numt++;
else if (a[i] == 'A')
numat = (numat + numt) % 1000000007;
else
numpat = (numpat + numat) % 1000000007;
}

cout << numpat << endl;

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: