您的位置:首页 > 其它

poj 3723 Conscription(最大生成树 kruscal)

2017-04-28 21:33 483 查看
Conscription

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13250 Accepted: 4637
Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some
relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB.
Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.

The first line of each test case contains three integers, N, M and R.

Then R lines followed, each contains three integers xi, yi and di.

There is a blank line before each test case.

1 ≤ N, M ≤ 10000

0 ≤ R ≤ 50,000

0 ≤ xi < N

0 ≤ yi < M

0 < di < 10000

Output

For each test case output the answer in a single line.
Sample Input
2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output
71071
54223

Source

POJ Monthly Contest – 2009.04.05, windy7926778

tips:题目叙述说每个人都只被征兵一次,所以我们只需找到最大的亲密度和。另外,因为男女下标都是从0开始,需要吧女生下标改为从n开始。

最终结果就是(n+m)*10000-最大生成树

#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<cstdio>
using namespace std;

struct edge{
int u,v,w;
friend bool operator <(edge e1,edge e2)
{
return e1.w>e2.w;
}
};
int f[22222];
vector<edge>edges;
int find(int x)
{
return f[x]<0?x:f[x]=find(f[x]);
}
int merge(int x,int y)
{
int rx=find(x);
int ry=find(y);

if(rx!=ry)
{
f[rx]+=f[ry];
f[ry]=rx;
return 1;
}
return 0;
}
int kruscal(int n,int m)//n个点m条边
{
memset(f,-1,sizeof(f));
sort(edges.begin(),edges.end());
int cnt=0;int flag=0;
for(int i=0;i<edges.size();i++)
{
int x=edges[i].u;int y=find(edges[i].v);
if(merge(x,y))
{
cnt+=edges[i].w;
if(++flag==n-1)break;
}
}
return cnt;
}
int main()
{
int t;cin>>t;
while(t--)
{
edges.clear();
int n,m,r;cin>>n>>m>>r;
while(r--)
{
int a,b,c;scanf("%d %d %d",&a,&b,&c);
edges.push_back(edge{a,b+n,c});
}
int ans=kruscal(n+m,r);
cout<<(n+m)*10000-ans<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: