您的位置:首页 > 其它

Silver Cow Party POJ - 3268

2017-04-28 17:53 316 查看
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road i requiresTi (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X 

Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.

Output
Line 1: One integer: the maximum of time any one cow must walk.

Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3


Sample Output
10


Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

单元最短路:

spfa

#include <iostream>
#include<stdio.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<map>
#include<queue>
#include<vector>
#include<deque>
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int n,dis[1001],vis[1001],mp[1001][1001][3],x;
int m,ans[1001];
vector<int>p[1001];
void spfa(int temp)
{
queue<int>que;
mem(vis,0);
for(int i=1; i<=n; i++)
{
dis[i]=inf;
}
while(!que.empty())que.pop();
vis[x]=1;
dis[x]=0;
que.push(x);
while(!que.empty())
{
int u=que.front();
que.pop();
vis[u]=0;
for(int i=1; i<=n; i++)
{
int w=mp[u][i][temp];
if(dis[i]>dis[u]+w)
{
dis[i]=dis[u]+w;
if(vis[i]==0)
{
vis[i]=1;
que.push(i);
}
}
}
}
for(int i=1; i<=n; i++)
{
ans[i]+=dis[i];
}
}
int main()
{
while(~scanf("%d%d%d",&n,&m,&x))
{
mem(mp,inf);
int v,u,t;
for(int i=0; i<m; i++)
{
scanf("%d%d%d",&u,&v,&t);
if(mp[u][v][0]>t)
mp[u][v][0]=t;
if(mp[v][u][1]>t)
mp[v][u][1]=t;
}
mem(ans,0);
spfa(0);
spfa(1);
int maxx=0;
for(int i=1; i<=n; i++)
{
maxx=max(maxx,ans[i]);
}
printf("%d\n",maxx);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: