您的位置:首页 > 其它

Jersey Politics POJ - 2454

2017-04-28 13:18 260 查看
传送门

In the newest census of Jersey Cows and Holstein Cows, Wisconsin cows have earned three stalls in the Barn of Representatives. The Jersey Cows currently control the state's redistricting committee. They want to partition the state
into three equally sized voting districts such that the Jersey Cows are guaranteed to win elections in at least two of the districts. 

Wisconsin has 3*K (1 <= K <= 60) cities of 1,000 cows, numbered 1..3*K, each with a known number (range: 0..1,000) of Jersey Cows. Find a way to partition the state into three districts, each with K cities, such that the Jersey Cows have the majority percentage
in at least two of districts. 

All supplied input datasets are solvable.

Input
* Line 1: A single integer, K 

* Lines 2..3*K+1: One integer per line, the number of cows in each city that are Jersey Cows. Line i+1 contains city i's cow census.

Output
* Lines 1..K: K lines that are the city numbers in district one, one per line 

* Lines K+1..2K: K lines that are the city numbers in district two, one per line 

* Lines 2K+1..3K: K lines that are the city numbers in district three, one per line

Sample Input
2
510
500
500
670
400
310


Sample Output
1
2
3
6
5
4


Hint
Other solutions might be possible. Note that "2 3" would NOT be a district won by the Jerseys, as they would be exactly half of the cows.

题意:给你一个3*k大小的数组
找出一个序列使得至少其中两组k大小的数组的总和>500*k;

先排序找出最小的序列号。
再在剩下的2*k里随机
#include <vector>
#include <iostream>
#include <string>
#include <map>
#include <stack>
#include <cstring>
#include <queue>
#include <list>
#include <cstdio>
#include <set>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <iomanip>
#include <cctype>
#include <sstream>
#include <functional>
#include <time.h>
using namespace std;

#define pi acos(-1)
#define endl '\n'
#define srand() srand(time(0));
#define me(x) memset(x,0,sizeof(x));
#define foreach(it,a) for(__typeof((a).begin()) it=(a).begin();it!=(a).end();it++)
#define close() ios::sync_with_stdio(0);
typedef long long LL;
const int INF=0x3f3f3f3f;
const LL LINF=0x3f3f3f3f3f3f3f3fLL;
//const int dx[]={-1,0,1,0,-1,-1,1,1};
//const int dy[]={0,1,0,-1,1,-1,1,-1};
const int maxn=1e3+5;
const int maxx=1e6+100;
const double EPS=1e-7;
const int MOD=1000000007;
#define mod(x) ((x)%MOD);
template<class T>inline T min(T a,T b,T c) { return min(min(a,b),c);}
template<class T>inline T max(T a,T b,T c) { return max(max(a,b),c);}
template<class T>inline T min(T a,T b,T c,T d) { return min(min(a,b),min(c,d));}
template<class T>inline T max(T a,T b,T c,T d) { return max(max(a,b),max(c,d));}
//typedef tree<pt,null_type,less< pt >,rb_tree_tag,tree_order_statistics_node_update> rbtree;
/*lch[root] = build(L1,p-1,L2+1,L2+cnt);
rch[root] = build(p+1,R1,L2+cnt+1,R2);中前*/
/*lch[root] = build(L1,p-1,L2,L2+cnt-1);
rch[root] = build(p+1,R1,L2+cnt,R2-1);中后*/
long long gcd(long long a , long long b){if(b==0) return a;a%=b;return gcd(b,a);}
int a[200],c[200];
bool cmp(int x,int y)
{
return a[x]>a[y];
}
int main()
{
int k;
scanf("%d",&k);
for(int i=1;i<=3*k;i++)
{
scanf("%d",&a[i]);
c[i]=i;
}
sort(c+1,c+3*k+1,cmp);
while(1)
{
int cnt1=0,cnt2=0;
for(int i=1;i<=k;i++)
cnt1+=a[c[i]];
for(int i=(k+1);i<=2*k;i++)
cnt2+=a[c[i]];
if(cnt1>k*500&&cnt2>k*500)
{
for(int i=1;i<=3*k;i++)
cout<<c[i]<<endl;
return 0;
}
int x=rand()%k+1,y=rand()%k+k+1;
swap(c[x],c[y]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: