您的位置:首页 > 其它

杭电1013 之 Digital Roots

2017-04-27 21:41 465 查看
[align=left]Problem Description[/align]
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

[align=left]Input[/align]
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

[align=left]Output[/align]
For each integer in the input, output its digital root on a separate line of the output.

[align=left]Sample Input[/align]

24
39
0

[align=left]Sample Output[/align]

6
3

题意:给你一个数,求这个数的各个位数之和,如果和为一位数,输出,否则循环该步骤
刚开始直接模拟,感觉没什么问题,后来才知道要用字符串,对9取余即可,这题真坑

错误代码:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int fun(int n)
{
int sum=0;
while(n!=0)
{
sum+=(n%10);
n/=10;
}
return sum;
}

int main()
{
int n;
while(cin>>n && n)
{
while(log10(n)>=1)
{
n=fun(n);
}
cout<<n<<endl;
}
return 0;
}

AC代码如下:#include<iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=1e4;

char s[maxn];

int main()
{
int n=0;
while(cin>>s && s[0]!='0')
{
n=0;
int len=strlen(s);
for(int i=0;i<len;i++) n=n+s[i]-'0';
while(n>9) n%=9;
if(n==0) n+=9;
cout<<n<<endl;

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: