您的位置:首页 > 其它

杭电1002(大数A+B) 之 A + B Problem II

2017-04-27 12:33 375 查看
[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
4000

112233445566778899 + 998877665544332211 = 1111111111111111110

AC代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

string a,b;

int main()
{
int t;
char s;
cin>>t;
for(int l=1;l<=t;l++)
{
cin>>a>>b;
s='0';
string c=a;
string d=b;
int n=a.length();
int m=b.length();
if(n>=m)
{
for(int i=n-1,j=m-1;i>=0 || j>=0;i--)
{
if(i>=0 && j>=0)
{
if(a[i]+b[j]-'0'-'0'>=10)
{
if(i-1>=0)
a[i-1]++;
else
s='1';
a[i]=(a[i]+b[j]-'0'-10);
}
else
{
a[i]=(a[i]+b[j]-'0');
}
}
if(j>=0) j--;
}
}
else
{
for(int i=m-1,j=n-1;i>=0 || j>=0;i--)
{
if(i>=0 && j>=0)
{
if(a[j]+b[i]-'0'-'0'>=10)
{
if(i-1>=0)
b[i-1]++;
else
s='1';
b[i]=(a[j]+b[i]-'0'-10);
}
else
{
b[i]=(a[j]+b[i]-'0');
}
}
if(j>=0) j--;
}
}
printf("Case %d:\n",l);
cout<<c<<" + "<<d<<" = ";
if(s=='1') cout<<s;
if(n>=m) cout<<a<<endl;
else cout<<b<<endl;
if(l<t) cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: