您的位置:首页 > 其它

HDU 1133

2017-04-27 07:42 190 查看


Buy the Ticket

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6809    Accepted Submission(s): 2824


Problem Description

The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person. 

Note: initially the ticket-office has no money. 

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.

 

Input

The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.

 

Output

For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.

 

Sample Input

3 0
3 1
3 3
0 0

 

Sample Output

Test #1:
6
Test #2:
18
Test #3:
180

这道题就是要在N个100的前面摆上N个或者N个以上的50的人,然后全排列。

至于N大于M的时候就没有任何情况会符合条件。而且还涉及到精度的问题。

别人的思路

m>=n时,序列总数为:m+n个位置中选出m个放上0,C(m+n, n) *m!*n!;

则合法数目=序列总数-不合法数目;

我们来考虑不合法序列的数目,

因为50元的共m个,当1的个数等于n=m+1是,无论怎样排列总是不合法!!即C(m+n,m+1)*m!*n!;

此序列即是不合法队列。

合法队列=C(m+n, n) *m!*n!-C(m+n,m+1)*m!*n! 化简得 (m+n)!*(m-n+1)/(m+1);

#include<bits/stdc++.h>
using namespace std;
#define N 100
const int M=10000;
int main()
{
int i,j,m,n,cnt=1;
int a
;
while(scanf("%d%d",&m,&n),m||n)
{
printf("Test #%d:\n",cnt++);
if(m<n)
{
printf("0\n");
continue;
}
memset(a,0,sizeof(a));
a[0]=1;
for(i=1;i<=n+m;i++)
{
if(n!=0&&i==m+1)
continue;
for(j=0;j<N;j++)
{
a[j]=a[j]*i;
}
for(j=1;j<N;j++)
{
a[j]=a[j]+a[j-1]/M;
a[j-1]=a[j-1]%M;
}
}
if(n!=0)
{
for(i=0;i<N;i++)
a[i]=a[i]*(m-n+1);
}
for(i=1;i<N;i++)
{
a[i]=a[i]+a[i-1]/M;
a[i-1]=a[i-1]%M;
}
int flag=0;
for(i=N-1;i>=0;i--)
{
if(flag==1)
printf("%04d",a[i]);
else if(a[i]!=0)
{
flag=1;
printf("%d",a[i]);
}
}
printf("\n");
}
return 0;
}

还有一种思路就是DP,不过DP的方法明显不如这种方法简单明了。

递归也行。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息