您的位置:首页 > 其它

hdu oj Pick The Sticks(01背包)

2017-04-26 21:22 190 查看
Problem Description

The story happened long long ago. One day, Cao Cao made a special order called “Chicken Rib” to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he’s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an

L

length segment. And the gold sticks as segments too. There were many gold sticks with different length

a

i

and value

v

i

. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what’s the maximum value of the gold sticks Xiu Yang could have taken?

Input

The first line of the input gives the number of test cases,

T(1≤T≤100)

.

T

test cases follow. Each test case start with two integers,

N(1≤N≤1000)

and

L(1≤L≤2000)

, represents the number of gold sticks and the length of the container stick.

N

lines follow. Each line consist of two integers,

a

i

(1≤

a

i

≤2000)

and

v

i

(1≤

v

i



10

9

)

, represents the length and the value of the

i

th

gold stick.

Output

For each test case, output one line containing Case #x: y, where

x

is the test case number (starting from 1) and

y

is the maximum value of the gold sticks Xiu Yang could have taken.

Sample Input

4

3 7

4 1

2 1

8 1

3 7

4 2

2 1

8 4

3 5

4 1

2 2

8 9

1 1

10 3

Sample Output

Case #1: 2

Case #2: 6

Case #3: 11

Case #4: 3

题意:输入t,表示t组样例, 输入n,len,表示物品的个数和容器长度。输入n行a,v表示没个物品的长度和价值。每个物品只要能有一半放在容器上就可以(为了平衡,如果是一个物品的话不论它有多长都可以放在这个容器上),不可以重叠,求这个容器可以放最大的价值是多少。

分析:dp[i][j][k]表示前i个物品中放入长度为j的容器中有k个物品在边缘的最大价值。

代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string>
#include<string.h>
using namespace std;
typedef  long long  ll;
const int maxn=1e3+10;
int a[maxn],t,n,L,cnt=0;
ll dp[5000][4],val[maxn];
int main()
{
scanf("%d",&t);
while(t--)
{
cnt++;
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&L);
L*=2;//防止出现浮点型
ll MAX=0;
for(int i=0; i<n; i++)
{
scanf("%d%lld",&a[i],&val[i]);
a[i]*=2, MAX=max(MAX,val[i]);
}
for(int i=0; i<n; i++)
{
for(int j=L; j>=a[i]/2; j--)
{
for(int k=0; k<3; k++)
{
if(j>=a[i])
dp[j][k]=max(dp[j][k],dp[j-a[i]][k]+val[i]);
if(k)
dp[j][k]=max(dp[j][k],dp[j-a[i]/2][k-1]+val[i]);
MAX=max(MAX,dp[j][k]);
}
}
}
printf("Case #%d: %lld\n",cnt,MAX);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: