您的位置:首页 > 大数据 > 人工智能

POJ 2027 No Brainer

2017-04-26 20:57 519 查看
No Brainer

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 27861 Accepted: 18316
Description

Zombies love to eat brains. Yum.
Input

The first line contains a single integer n indicating the number of data sets. 

The following n lines each represent a data set. Each data set will be formatted according to the following description: 

A single data set consists of a line "X Y", where X is the number of brains the zombie eats and Y is the number of brains the zombie requires to stay alive. 

Output

For each data set, there will be exactly one line of output. This line will be "MMM BRAINS" if the number of brains the zombie eats is greater than or equal to the number of brains the zombie requires to stay alive. Otherwise, the line will be "NO BRAINS". 
Sample Input
3
4 5
3 3
4 3

Sample Output
NO BRAINS
MMM BRAINS
MMM BRAINS

//超级大水题
#include <iostream>
#include <cstdio>
using namespace std;
int main(int argc, const char * argv[]) {
int n,x,y;
cin>>n;
while(scanf("%d %d",&x,&y)&&n)
{
if(x>=y)
cout<<"MMM BRAINS"<<endl;
else
cout<<"NO BRAINS"<<endl;
n--;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: